Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress How to Install WordPress on Your Computer How to Install WordPress on Your Computer How to Enable Email for WordPress on Your Computer

Faoud Mohammed
Faoud Mohammed
1,348 Points

Entered Info Correctly but getting debug error

I entered the information correct but I am getting this debug message,

SMTP ERROR: Failed to connect to server: php_network_getaddresses: getaddrinfo failed: No such host is known. (0)SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Can someone help

Faoud Mohammed
Faoud Mohammed
1,348 Points

ok guys I figured it out, apparently when you install an update on Wordpress and enter the configuration info and send the test email, you have to go into the security setting in your gmail account and turn on the "Allow less secure apps: ON" in the security settings off your account although the debug info (shown before) will still come up. But the will still get the test email.

CLIENT -> SERVER: EHLO wpdemo.dev CLIENT -> SERVER: AUTH LOGIN CLIENT -> SERVER: ZmFvdWQubW9oZEBnbWFpbC5jb20= CLIENT -> SERVER: UmVwYWlyMSE= CLIENT -> SERVER: MAIL FROM:faoud.mohd@gmail.com CLIENT -> SERVER: RCPT TO:faoud.mohd@gmail.com CLIENT -> SERVER: DATA CLIENT -> SERVER: Date: Fri, 20 Oct 2017 05:09:16 +0000 CLIENT -> SERVER: To: faoud.mohd@gmail.com CLIENT -> SERVER: From: Faoud faoud.mohd@gmail.com CLIENT -> SERVER: Subject: Test Email CLIENT -> SERVER: Message-ID: 02f2403ec3f1890842aac4474ce5153b@wpdemo.dev CLIENT -> SERVER: X-Mailer: PHPMailer 5.2.22 (https://github.com/PHPMailer/PHPMailer) CLIENT -> SERVER: MIME-Version: 1.0 CLIENT -> SERVER: Content-Type: multipart/alternative; CLIENT -> SERVER: boundary="b1_02f2403ec3f1890842aac4474ce5153b" CLIENT -> SERVER: Content-Transfer-Encoding: 8bit CLIENT -> SERVER: CLIENT -> SERVER: This is a multi-part message in MIME format. CLIENT -> SERVER: CLIENT -> SERVER: --b1_02f2403ec3f1890842aac4474ce5153b CLIENT -> SERVER: Content-Type: text/plain; charset=us-ascii CLIENT -> SERVER: CLIENT -> SERVER: Test#1 From my local WordPress Install CLIENT -> SERVER: CLIENT -> SERVER: CLIENT -> SERVER: --b1_02f2403ec3f1890842aac4474ce5153b CLIENT -> SERVER: Content-Type: text/html; charset=us-ascii CLIENT -> SERVER: CLIENT -> SERVER: Test#1 From my local WordPress Install CLIENT -> SERVER: CLIENT -> SERVER: CLIENT -> SERVER: CLIENT -> SERVER: --b1_02f2403ec3f1890842aac4474ce5153b-- CLIENT -> SERVER: CLIENT -> SERVER: . CLIENT -> SERVER: QUIT

So remember to turn off the setting when you are done in your gmail account.