Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Blog Reader Android App Exploring the Master-Detail Template Creating a Project Using the Master-Detail Template

Brandon Parker
Brandon Parker
13,242 Points

Error Message

I'm getting the below error message when I start eclipse: This Android SDK requires Android Developer Toolkit version 23.0.0 or above. Current version is 22.6.3.v201404151837-1123206. Please update ADT to the latest version.

When I select "Check for updates" it returns nothing and I can't find a solution on stack overflow.

Help?

2 Answers

Hi Brandon,

I had the same issue this morning.

Just follow these steps

1) Go to Eclipse -> Help -> Install New Software

2) In the next window that appears click Add

3) In the Add repository windows type ADT Plugin for Name & https://dl-ssl.google.com/android/eclipse/ (do not omit the s in https , its important) . Click OK*

4) Once you lick OK you will see Developer Tools listed under available software. Select the Developer Tools, click next and continue till it installs developer 23.0.0

5) Restart Eclipse and voila! all errors are gone :)

Hope it helps

Brandon Parker
Brandon Parker
13,242 Points

Thanks for the response Gunjeet but I still get the following in the detail message:

Cannot complete the install because of a conflicting dependency. Software being installed: Android DDMS 23.0.0.1245622 (com.android.ide.eclipse.ddms.feature.feature.group 23.0.0.1245622) Software currently installed: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508) Only one of the following can be installed at once: Dalvik Debug Monitor Service 23.0.0.1245622 (com.android.ide.eclipse.ddms 23.0.0.1245622) Dalvik Debug Monitor Service 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ddms 22.6.2.v201403212031-1085508) Cannot satisfy dependency: From: ADT Package 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.feature.group 22.6.2.v201403212031-1085508) To: com.android.ide.eclipse.ddms.feature.group 22.6.2 Cannot satisfy dependency: From: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508) To: com.android.ide.eclipse.adt.package.feature.group [22.6.2.v201403212031-1085508] Cannot satisfy dependency: From: Android DDMS 23.0.0.1245622 (com.android.ide.eclipse.ddms.feature.feature.group 23.0.0.1245622) To: com.android.ide.eclipse.ddms [23.0.0.1245622] Cannot satisfy dependency: From: Android DDMS 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ddms.feature.group 22.6.2.v201403212031-1085508) To: com.android.ide.eclipse.ddms [22.6.2.v201403212031-1085508]

I believe you might need to remove the older ADT Plugin