Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Development Tools Console Foundations Installing Software Building Software From Source

Sean Pierce Sumler
Sean Pierce Sumler
18,968 Points

error message after trying to open the tar.gz file in Virtual Machine

Hi everyone. I'm receiving this error message when trying to open this file, "sqlite-autoconf-3081101.tar.gz" in my virtual machine.

The error message I am receiving is this -> gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

I've followed the instructions very carefully. If anyone has any insight, I would appreciate the help. For context, I believe the course video will be linked to this question.

Thanks in advance!

I'm getting the same error message, except it is preceded with: tar: This does not look like a tar archive.

I've tried opening a new session and restarting the virtual machine but keep getting the same error message. Suggestions please.

2 Answers

Sean Pierce Sumler
Sean Pierce Sumler
18,968 Points

I knew that as soon as I asked, it would be sorted out. I just restarted my "virtual machine" session and my commands began working again. ¯_(ツ)_/¯

I encountered this error and this is how I solved it: In my case it looked like the file didn't download properly. I removed it with 'rm <filename>' and downloaded it again with 'curl -O <url>' and then re-ran the 'tar' command.