Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS

Error message when compiling CrystalBall app

Hi,

I recently started the CrystalBall app tutorial in the iOS Development track. I have done nothing to the project besides creating it, and every time I try to compile it I get the following error message:

"iOS Simulator failed to install the application."

Also, the default background color for the Storyboard is set to white but what I get is a black background color.

It should be noted that I use Xcode 5.0.2 and my deployment target is iOS 7.0. I don't get the error message when compiling to iOS versions below iOS 7. Apple wrote in its release notes for Xcode 5.0.2 that it resolved some issues related to the iOS Simulator, but clearly not this particular issue.

Is anybody experiencing this issue now? If so, have you found any fix for it?

3 Answers

Amit Bijlani
STAFF
Amit Bijlani
Treehouse Guest Teacher

Try resetting the simulator. From the simulator menu select iOS Simulator -> Reset Content and Settings

I had already tried that, but with no luck.

What fixed my issue was reinstalling Xcode. Now it works like a charm.

Rashii Henry
Rashii Henry
16,433 Points

Have you tried..

from the menubar in Xcode, click on product>>clean

sometimes doing a product clean handles those weird errors in Xcode.

I fixed the issue by reinstalling Xcode, but thanks for the advice - I'll keep it in mind the next time Xcode gets weird.