Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Animations and Transitions Animations Basics Property Animation

ERROR: No toolchains found in the NDK toolchains folder for ABI with prefix: mipsel-linux-android

please help stuck because the project you are worked with is older version i want to use this but it is not working please see that it work in current version of android:the link to github-code:https://github.com/treehouse/android-animations-transitions

3 Answers

Hi Sai. No, you do not need to work on that old version to follow the course. I did it a few days ago using Android SDK 28. I first tried to download the project and update it, but like you, I was having too many errors. In the end, to save time, I created a brand new project (with compile and targetSdkVersion 28 and minSdkVersion 21), copy/pasted all the classes and resource files from the old project in it and updated the code where needed.

It worked absolutely fine and was much easier. I hope it will work for you too. Good luck!

Lauren Moineau can you please explain step wise how did it!!!! I tried in every possible way i thought off please help me!!

Hi Sai. Before you move any further if you're using the standard Support Library and not AndroidX, remember to use the 8.8.1 version of Butterknife. You will get an error with the latest version (10.1.0) as it uses androidX:

    implementation 'com.jakewharton:butterknife:8.8.1'
    annotationProcessor 'com.jakewharton:butterknife-compiler:8.8.1'

If you want to follow my hack, which, as alastair cooper pointed out, is not the best practice solution (I've actually just managed to update the old project right now in a few minutes. So I was probably having a bad day the other day :) ) :

  • start by creating a new project (with minSdkVersion 21)
  • add all the dependencies from the old project (remember it's "implementation" now, not "compile")
  • copy/paste the classes/packages and resource xml files (you might need to update the package name if you used a different one and also some of the imports in that case)
  • The @Bind annotation is deprecated. You need to use @BindView now.
  • Make some updates where needed (java and xml)

I hope that helps :)

i had tried every thing which you just said but not working and i had an idea you create a project in the same way you described on you android studio current workable version and upload in the github and pass me the link so that i can clone and use it.it please please help me!

Hi Sai. Did you managed or are you still struggling to update the code?

alastair cooper
alastair cooper
28,199 Points

The error looks like a build tools problem

In your build.gradle file(app) check the build tools version, then open your SDK manager and make sure you have the correct version installed. Then either install the correct version, or, better, update your build .gradle file to use the newer version you have installed (then sync your project)

failing that, follow the blue links/actions in the run window as Android Studio is pretty good at sorting these things out by itself if you let it, but it won't do it without asking you

Also, check you are using the correct versions of butterknife and any other dependencies the app requires. Some of the 3rd party libraries change regularly and the versions used in some of the courses are out of date now

Hope this helps

no i need to work on older project to fallow android studio lessons in the team tree house .he gave me a github link but current sdk version and grandle is not supporting so how to make it work please help!.

alastair cooper
alastair cooper
28,199 Points

As Lauren points out, there is no need to use the old versions to follow the course. I only completed it myself about a month ago and just followed the blue links in the run window to fix the problems and use newer build-tools etc.

Lauren's solution will work just fine for a small app like this, but you can imagine with a larger project it would take ages and be an easy source of errors. Far better to play around with gradle for a while (if you mess it up completely you can always delete the project and download it again). I am still a beginner with gradle but the practise I have had with it following these older courses has meant I beginning to understand bits of it.

Alastair, absolutely, I couldn't agree more. I've never had a problem updating old projects so far and only went nuclear with this one because I was short on time and, as you said perfectly, it was a small project. It's the first time I do this. I also much prefer taking the time to deal with Gradle because you learn more that way and that would be the way to go with a bigger project anyway.