Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress Installing WordPress Locally Installing WordPress Locally Enable Email for WordPress on Your Computer

Khoa Nguyen
Khoa Nguyen
4,735 Points

Error sending test email

SMTP ERROR: Failed to connect to server: (0)SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Tomáš Komprs
Tomáš Komprs
14,057 Points

For Gmail, I had to try create an app password at first. this didn't work. But what help me was: in these settings: Type of Encryption: None SSL/TLS STARTTLS select STARTTLS instead of SSL/TLS

3 Answers

It finally worked after 3 hours!

I used gmail.

What I did:

  1. Create a "2 authentication" for GMAIL, then Create a "Application Password"
  2. In GMAIL, find "allow less secure apps". (According to others -- sometimes it takes an hour to take affect)
  3. In WordPress Admin -- EASY WP SMPT settings I then changed SSL/TLS , to STARTTLS
Brad Rollins
Brad Rollins
1,914 Points

Thanks Anthony! I just followed 2 of the steps you listed and it work immediately for me.

  1. In GMAIL, find "allow less secure apps". (According to others -- sometimes it takes an hour to take affect)

  2. In WordPress Admin -- EASY WP SMPT settings I then changed SSL/TLS , to STARTTLS

Ryan Thacker
Ryan Thacker
4,201 Points

Change to STARTTLS

Daniel Fitzhugh
Daniel Fitzhugh
9,715 Points

I also had to create an App Password in Gmail, because I had two-factor authentication turned on, and Gmail had no way of performing the the second authentication.

https://support.google.com/accounts/answer/185833

Diana Vazquez
Diana Vazquez
1,395 Points

Thanks sooo much!!! I was wracking my brain about this! The link you posted was super helpful.