Welcome to the Treehouse Community
The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)
Looking to learn something new?
Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.
Error when installing rails: activesupport requires Ruby version >= 2.2.2. Video only seems to want 2.0.0
Error when installing rails: activesupport requires Ruby version >= 2.2.2. Video only seems to want 2.0.0. Installed the 2.0.0 (x64) version as per video. Worked fine right up until the install rails moment. Should I just go ahead and install the 2.2.2 version? Any advice would be much appreciated! Cheers
Adam Rainsby2,848 Points
You can upgrade your version of ruby and then you can use ActiveSupport 5 or you could downgrade to ActiveSupport to 4.2.6 which will work with ruby 2.0.0.
ActiveSupport 5 is newer - it came out about a week ago. If you want to follow the course exactly downgrade ActiveSupport otherwise get the newer version. I'm pretty sure it will be mostly compatible anyway.
Hey I am having the same issue. How did you downgrade to the Active Support 4.2.6 ??