Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP Build a Simple PHP Application Getting Started with PHP Install PHP on Windows 7

Error when trying to "Start" Apache

When I click the Start action for Apache in the XAMPP Control Panel I get the an error message.

3:32:11 PM [Apache] Error: Apache shutdown unexpectedly. 3:32:11 PM [Apache] This may be due to a blocked port, missing dependencies, 3:32:11 PM [Apache] improper privileges, a crash, or a shutdown by another method. 3:32:11 PM [Apache] Press the Logs button to view error logs and check 3:32:11 PM [Apache] the Windows Event Viewer for more clues 3:32:11 PM [Apache] If you need more help, copy and post this 3:32:11 PM [Apache] entire log window on the forums

How can I get this to work?

7 Answers

Before reading the next post where i'm linking you to, be sure that no program is opened that might cause problems.

http://stackoverflow.com/questions/18300377/xampp-apache-error-apache-shutdown-unexpectedly

There are some solutions on that page and i hope that one of them works. If not, then i'm out of ideas XD

Thank you! That link lead me to this link: http://stackoverflow.com/questions/14245474/apache-wont-run-in-xampp and I changed port 80 to 8080 in the config file to get it to work.

Do you have Skype open by any chance? If so, close it and re-start it ( Apache that is ).

Thanks for the reply. However, I do not have Skype on my Computer.

Ronald Barfield
Ronald Barfield
1,133 Points

This seems to have worked for me thank you.

B D
B D
2,703 Points

If I'm not mistaken, a lot of ISPs are starting to block port 80.

So try going to: Config > Apache (httpd.conf) > and change all port 80 to 8080

Just do a ctrl + f to find all the 80s.

There were 3 that I changed:

  • Listen 12.34.56.78:8080

  • Listen 8080

  • ServerName localhost:8080

It worked for me.

Gregory Anuhin
Gregory Anuhin
3,640 Points

I changed the ports its didnt help then i turned off my skype and its working now thanks ))

Nenad Jovic
Nenad Jovic
7,883 Points

I have problem with Apache running.. http://prntscr.com/5o1pro Can someone help me out?

I did netststat -anbo, and

Active Connections

Proto Local Address Foreign Address State PID TCP 0.0.0.0:21 0.0.0.0:0 LISTENING 7908 [filezillaserver.exe] TCP 0.0.0.0:135 0.0.0.0:0 LISTENING 468 RpcSs [svchost.exe] TCP 0.0.0.0:443 0.0.0.0:0 LISTENING 4588 [vmware-hostd.exe]

we see here vmware-hostd.exe is already resident on that port stopped process and xampp will now launch

It's helpful to go to the c:\xampp\apachi\bin directory from a command prompt and type httpd

as the error log for some reason on the early part of startup does not make it into the error file just stderr to a console

in my case originally I got C:\xampp\apache\bin>httpd.exe (OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : AH00072: make_sock: could not bind to address [::]:443

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : AH00072: make_sock: could not bind to address 0.0.0.0: 443 AH00451: no listening sockets available, shutting down AH00015: Unable to open logs

Gary Calhoun
Gary Calhoun
10,317 Points

Thanks the port 8080 trick worked for me as well.