Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

PHP Drupal Basics Getting Started with Drupal Setting Up WAMP for Windows

Jake Summerlin
Jake Summerlin
3,214 Points

Error when trying to turn on WAMPserver

I am unable to turn on the WAMPserver because an error keeps popping up. The title of the error is Aestan Tray Menu It says.. Could not execute menu item (internal error) [Exception] Could not perform service action: The service has not been started

But I've clicked Start All Services many times. Did I miss something?

Thanks everybody

And of course you clicked the online button. srry, dumb comment of the obivious. but had to ask? ohh and today it's wampserver 3. so this is a little old.

4 Answers

Jake Summerlin
Jake Summerlin
3,214 Points

Thanks for the response Vishal.

I uninstalled it and reinstalled it. And rebooted my computer. The error still arises. Any other suggestions?

Thanks for the help

Same error for me! Reinstall and reboot dosnt solve.

Sam Katz
Sam Katz
2,986 Points

Make sure to right click and say run as administrator.

Leah Thompson
Leah Thompson
4,197 Points

Hey Jake,

I'm sure you've probably found a fix for this by now, but I figure I'll provide my solution in case anyone else runs into this error when trying to install WAMP.

You might have another server installed on your localhost in which Apache was already installed and using port 80. I had tried installing Drupal prior to taking this course with DAMP (Drupal's own server environment), so there was a conflict with trying to start Apache from WAMP as the port was already in use. I simply uninstalled the DAMP server and restarted my machine, then re-installed WAMP and everything worked perfectly. You might also be able to simply put your other server offline while you're running WAMP, but I didn't think to try this before uninstalling, as I wasn't using the other server anyway.

If you don't want to uninstall your other server, you can change your localhost port number for WAMP in the Apache > httpd.conf document. Just CTRL+F '80' and change to '8080' (there should be two instances of this). You'll then have to access phpMyAdmin by typing in the port number when you access the database (i.e. http://localhost:8080/phpmyadmin). There might be a way to redirect the phpMyAdmin link to this port from the WAMP dashboard, but I didn't troubleshoot that far into it, as uninstalling DAMP fixed the issue for me.

Also make sure Skype is not running when you are installing WAMP (force end the Skype application from the Task Manager, because even if you quit Skype it still runs in the background). If you previously installed WAMP while Skype was running, uninstall it, reboot your machine, and re-install without Skype running.

Hope this helps!