Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Java Spring Basics Introduction and Setting up Our Development Tools Gradle in Action

Error whenever I put compile 'com.springframework:spring-webmvc:4.3.3.RELEASE'

For some reason I get an error whenever i refresh the gradle after I put compile 'com.springframework:spring-webmvc:4.3.3.RELEASE' , Why is that? :( This is what it looks like: https://drive.google.com/file/d/0B1S7e8-0MO-QdnhnM29tTy1TdFE/view?usp=sharing

1 Answer

Hi, I've changed it and I still have the same error :( https://drive.google.com/file/d/0B1S7e8-0MO-QVHZOdkNKS3BjQlU/view?usp=sharing

Alexander Nikiforov
.a{fill-rule:evenodd;}techdegree seal-36
Alexander Nikiforov
Java Web Development Techdegree Graduate 22,175 Points

Did you hit refresh button ?

It should work.

I even made video, where I type exactly as you say ...

Here take a look


Also could you tell me did you take 'Gradle workshop' here at Treehouse?


Did gradle worked for you in that course?

I need to know to check that if any other dependency can be added to your project...

For example did dependencies in this video worked for you?


Hi, yeah I took that workshop and the thing is during that time it worked but when I created a new project it wouldn't work anymore. I opened the video Adding Dependencies to trace back if I made a mistake but it turns out there was a problem with the Gradle Settings, the checkbox for offline work got checked. So when I unchecked it, everything works when I refresh it again. Thank you :)