Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Ruby Build a Simple Ruby on Rails Application Frontend Development Adding Interactivity

Failed to load resource: 404

Hi guys, I'm getting these lines in the console:

[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (bootstrap-theme.css.map.css, line 0)

[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (bootstrap.css.map.css, line 0)

I checked for the files and I do have them in my app/assets/stylesheets folder. I'm using Bootstrap 3.1.1 so I guess the problem might be somewhere between following the instructions in the video (for older Bootstrap version) and using the newest Bootstrap in my app.

Do you have any idea how could I solve this? Btw. the hovers are getting triggered. It's just when I try to use the following code that nothing happens (the class is not toggled to "hover" and thus links are not viewed): `` coffeescript $ -> $('.status').hover (event) -> # $(this).toggleClass("hover")

Hey guys, I solved the problem by renaming the files in my application's assets/stylesheets from bootstrap.css.map to bootstrap.css.map.css (which the error complained about) and bootstrap-theme.css.map to bootstrap-them.css.map.css. It works but it is still strange to me. Does anyone have an explanation for this bug?

Naomi Freeman
Naomi Freeman
Treehouse Guest Teacher

I don't have an explanation, but I have switched to using Foundation because it yells a lot less these days. Bootstrap used to be great before the most recent update, but with Rails I've found it faster to Foundation. Obviously this project you've already got going, but maybe give it a try in a future project.

1 Answer

Jaime Jayne
Jaime Jayne
882 Points

Bootstrap 3 comes with a boostrap.css.map file (and its equivalent minified version). If you add this to your assets/css folder it will load with no error. Alternatively you can remove the following line from the bootstrap.css file.
/*# sourceMappingURL=bootstrap.css.map */

The .map file is a source map for Firefox and Chrome debuggers. It enables DevTools (like console) to live-edit your preprocessor source files in the Sources panel.. further explanation is here https://developer.chrome.com/devtools/docs/css-preprocessors

Marcel Olszewski
Marcel Olszewski
2,008 Points

Still doesn't explain why its *.css.map.css.