WordPress Installing WordPress Locally Installing WordPress Locally Enable Email for WordPress on Your Computer

Bryson Gilreath
Bryson Gilreath
5,947 Points

For people having trouble with Gmail

If you're having trouble with Gmail try going to your Google account --> Sign-in & security --> Signing in to Google --> App passwords, and then creating an app password just for SMTP. Use that on the plugin settings instead of your main one.

I don't have this option. When I click on Signing in to Google, I don't have a link for App passwords. What should I do?

I managed to solve the problem. I only have three options for type of encryption: None, SSL/TLS, or STARTTLS. I had to select STARTTLS, not SSL?TLS. Now it works.

Hannah Mycock
Hannah Mycock
14,899 Points

I couldn't find an "App passwords" option either, but fixed the problem by allowing access from less secure apps.

Janet Leon
Janet Leon
6,902 Points

This works using STARTTLS!!!

7 Answers

Øystein Haugseth
Øystein Haugseth
15,672 Points

Using gmail, I fixed it by choosing STARTTLS as well, but it will throw an error. When it does, go to sign-in & security --> Device activity & security events and click on Review events. Click on the event and then Yes, that was me. It then worked for me.

Ben Myhre
Ben Myhre
27,309 Points

I went down this trail, as well, but it did not help. After I clicked "yes, it was me", it continued blocking me. I had to go to the google settings and change 'allow less secure apps' and then it worked. This is sort of concerning, really.

Aaron Parke
Aaron Parke
2,160 Points

I had to do this then also turn "Allow less secure apps" ON, then it worked for me!

Hi Hannah, I tried that first, but it didn't work for me. Maybe it has something to do with the mamp version. I'm using mamp pro.

Heidi Toft
Heidi Toft
1,894 Points

I get the following error when I tried setting up Easy SMTP:

Following error occured when attempting to send test email: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting Any ideas? I did try selecting STARTTLS and that did not work. I got a long error message.

Thanks for your help, Heidi

Nawal Tariq
Nawal Tariq
713 Points

I was getting an error but then I turned on the option of allowing less secure sign in in Gmail. That did not resolve the issue but then I saw this thread and changed my type of encryption to STARTTLS and it worked for me.

codingwithcats
codingwithcats
3,564 Points

Thanks Bryson Gilreath! This - along with changing authentication to STARTTLS - worked for me!