Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS

From Structs to Objects not building in XCode 6.

could not read data from '/Users/bijalba/Desktop/Development/sphere class/MyFirstObjectiveCProgramTests/MyFirstObjectiveCProgramTests-Info.plist': The file “MyFirstObjectiveCProgramTests-Info.plist” couldn’t be opened because there is no such file.

Receiving this error from the XCTest.framework on XCode 6.

Also, I reloaded everything and the XCTest.framework is bold + red on the left side when i expand "frameworks" by default. When I go to the path /applications/xcode.app/contents/developer/library/frameworks there is no XCTest.framework file, which is being referred to in frameworks.

EDIT: Just downgraded to 5.1.1 XCode and am getting the same error, but at least the XCTest.framework is now there and not missing....

I have it working in 5.1.1 XCode and I narrowed it down to one of two things that I was doing wrong.

  1. I was copying the files WITHIN MyFirstObjectiveCProgram into sphere class, so the structure was "sphere class>MyFirstObjectiveCProgram & the .xcodeproj file" instead of "sphere class>MyFirstObjectiveCProgram>MyFirstObjectiveCProgram & the .xcodeproj file".

  2. I redownloaded it following the link under the video, instead of using the version from previous chapters.

One of those two things fixed it!

4 Answers

Andrew Koines
Andrew Koines
4,986 Points

I had this same issue, but was able to get it working in Xcode 6.

I noticed that the error stated that the "MyFirstObjectiveCProgramTests/MyFirstObjectiveCProgramTests-Info.plist" file was missing, so I first tried simply redownloading the project files in case I had somehow deleted this file, but this does not appear to be the case.

I was able to resolve the issue with the following steps.

  1. Create a new XCode project (an OS X Cocoa application -- I initially thought it would be an iOS project but noticed that when you have the project files open in XCode there is a line indicating that you are in the "OS X SDK", so I figured that this was the correct project type).
  2. Create the missing MyFirstObjectiveCProgramTests folder.
  3. Move the .plist file from the new project into that folder and rename it to "MyFirstObjectiveCProgramTest-Info.plist".

I hope this helps!

Charlie O'Shea
Charlie O'Shea
18,737 Points

Andrew Koine solution worked for me, but it's a bit of a hassle that someone new to the language and program has to do all this to get a simple program to run.

Treehouse staff really need to look into these missing files, it seems to be affecting a lot of people on the forums and they just keep saying 'try it again' or 'are you sure you are unzipping the files?'

I also tried Christopher Bijalba's solutions before but they didn't work for me unfortunately.

Andrew King
Andrew King
3,411 Points

Just found this thread after making this post about getting the same issue.

The annoying thing is I can't find any information about -why- it's happening nor anything from Treehouse staff. You'd think they'd update the template project files, hardly a huge fix for them.

Amit Bijlani
STAFF
Amit Bijlani
Treehouse Guest Teacher

Sorry about that guys. I've updated the project templates to work with Xcode 6.