Welcome to the Treehouse Community
The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)
Looking to learn something new?
Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.
Julianna Kahn20,700 Points
Function Naming Conventions
I'm surprised to see that a function has been given the same name as the method createElement. Is that a convention that is frequently used?
Steven Parker208,478 Points
Not frequently, but in this case the new function is essentially an "override" of the document method so it makes sense for it to have the same name. It's also limited in scope to within the "createLI" function.