Ruby Installing a Ruby Development Environment Installing a Ruby Development Environment Installing Ruby on Mac

Gem Install Bundler errors.

When I type the command gem install bundler, I get these errors:

Ignoring binding_of_caller-0.7.2 because its extensions are not built. Try: gem pristine binding_of_caller --version 0.7.2 Ignoring byebug-5.0.0 because its extensions are not built. Try: gem pristine byebug --version 5.0.0 Ignoring debug_inspector-0.0.2 because its extensions are not built. Try: gem pristine debug_inspector --version 0.0.2 Ignoring executable-hooks-1.3.2 because its extensions are not built. Try: gem pristine executable-hooks --version 1.3.2 Ignoring gem-wrappers-1.2.7 because its extensions are not built. Try: gem pristine gem-wrappers --version 1.2.7 Ignoring json-1.8.3 because its extensions are not built. Try: gem pristine json --version 1.8.3 Ignoring nokogiri-1.6.6.2 because its extensions are not built. Try: gem pristine nokogiri --version 1.6.6.2 Ignoring sqlite3-1.3.10 because its extensions are not built. Try: gem pristine sqlite3 --version 1.3.10 Ignoring binding_of_caller-0.7.2 because its extensions are not built. Try: gem pristine binding_of_caller --version 0.7.2 Ignoring byebug-5.0.0 because its extensions are not built. Try: gem pristine byebug --version 5.0.0 Ignoring debug_inspector-0.0.2 because its extensions are not built. Try: gem pristine debug_inspector --version 0.0.2 Ignoring executable-hooks-1.3.2 because its extensions are not built. Try: gem pristine executable-hooks --version 1.3.2 Ignoring gem-wrappers-1.2.7 because its extensions are not built. Try: gem pristine gem-wrappers --version 1.2.7 Ignoring json-1.8.3 because its extensions are not built. Try: gem pristine json --version 1.8.3 Ignoring nokogiri-1.6.6.2 because its extensions are not built. Try: gem pristine nokogiri --version 1.6.6.2 Ignoring sqlite3-1.3.10 because its extensions are not built. Try: gem pristine sqlite3 --version 1.3.10 Error loading RubyGems plugin "/Users/kaityhallman/.rvm/gems/ruby-2.2.1@global/gems/executable-hooks-1.3.2/lib/rubygems_plugin.rb": cannot load such file -- executable-hooks/wrapper (LoadError) Error loading RubyGems plugin "/Users/kaityhallman/.rvm/gems/ruby-2.2.1@global/gems/gem-wrappers-1.2.7/lib/rubygems_plugin.rb": cannot load such file -- gem-wrappers (LoadError)

Eric Hanneken
Eric Hanneken
3,256 Points

You are on a Mac using RVM to manage Ruby versions, correct?

Can you show me the output of

rvm list rubies

and

rvm gemset list

and

gem list --local

?

Eric Hanneken

for rvm list rubies:

Warning! PATH is not properly set up, '/Users/kaityhallman/.rvm/gems/ruby-2.2.1/bin' is not at first place,
         usually this is caused by shell initialization files - check them for 'PATH=...' entries,
         it might also help to re-add RVM to your dotfiles: 'rvm get stable --auto-dotfiles',
         to fix temporarily in this shell session run: 'rvm use ruby-2.2.1'.

rvm rubies

=* ruby-2.2.1 [ x86_64 ]

# => - current
# =* - current && default
#  * - default

for rvm gemset list:

Warning! PATH is not properly set up, '/Users/kaityhallman/.rvm/gems/ruby-2.2.1/bin' is not at first place,
         usually this is caused by shell initialization files - check them for 'PATH=...' entries,
         it might also help to re-add RVM to your dotfiles: 'rvm get stable --auto-dotfiles',
         to fix temporarily in this shell session run: 'rvm use ruby-2.2.1'.

gemsets for ruby-2.2.1 (found in /Users/kaityhallman/.rvm/gems/ruby-2.2.1)
=> (default)
   global

for gem list --local

Ignoring binding_of_caller-0.7.2 because its extensions are not built.  Try: gem pristine binding_of_caller --version 0.7.2
Ignoring byebug-5.0.0 because its extensions are not built.  Try: gem pristine byebug --version 5.0.0
Ignoring debug_inspector-0.0.2 because its extensions are not built.  Try: gem pristine debug_inspector --version 0.0.2
Ignoring executable-hooks-1.3.2 because its extensions are not built.  Try: gem pristine executable-hooks --version 1.3.2
Ignoring gem-wrappers-1.2.7 because its extensions are not built.  Try: gem pristine gem-wrappers --version 1.2.7
Ignoring sqlite3-1.3.10 because its extensions are not built.  Try: gem pristine sqlite3 --version 1.3.10
Ignoring binding_of_caller-0.7.2 because its extensions are not built.  Try: gem pristine binding_of_caller --version 0.7.2
Ignoring byebug-5.0.0 because its extensions are not built.  Try: gem pristine byebug --version 5.0.0
Ignoring debug_inspector-0.0.2 because its extensions are not built.  Try: gem pristine debug_inspector --version 0.0.2
Ignoring executable-hooks-1.3.2 because its extensions are not built.  Try: gem pristine executable-hooks --version 1.3.2
Ignoring gem-wrappers-1.2.7 because its extensions are not built.  Try: gem pristine gem-wrappers --version 1.2.7
Ignoring sqlite3-1.3.10 because its extensions are not built.  Try: gem pristine sqlite3 --version 1.3.10
Error loading RubyGems plugin "/Users/kaityhallman/.rvm/gems/ruby-2.2.1@global/gems/executable-hooks-1.3.2/lib/rubygems_plugin.rb": cannot load such file -- executable-hooks/wrapper (LoadError)
Error loading RubyGems plugin "/Users/kaityhallman/.rvm/gems/ruby-2.2.1@global/gems/gem-wrappers-1.2.7/lib/rubygems_plugin.rb": cannot load such file -- gem-wrappers (LoadError)

*** LOCAL GEMS ***

actionmailer (4.2.4, 4.2.3)
actionpack (4.2.4, 4.2.3)
actionview (4.2.4, 4.2.3)
activejob (4.2.4, 4.2.3)
activemodel (4.2.4, 4.2.3)
activerecord (4.2.4, 4.2.3)
activesupport (4.2.4, 4.2.3)
arel (6.0.3)
bigdecimal (1.2.6)
binding_of_caller (0.7.2)
builder (3.2.2)
bundler (1.10.6)
bundler-unload (1.0.2)
byebug (5.0.0)
coffee-rails (4.1.0)
coffee-script (2.4.1)
coffee-script-source (1.9.1.1)
columnize (0.9.0)
debug_inspector (0.0.2)
erubis (2.7.0)
execjs (2.6.0)
executable-hooks (1.3.2)
gem-wrappers (1.2.7)
globalid (0.3.6)
i18n (0.7.0)
io-console (0.4.3)
jbuilder (2.3.1)
jquery-rails (4.0.4)
json (1.8.3, 1.8.1)
loofah (2.0.2)
mail (2.6.3)
mime-types (2.6.1)
mini_portile (0.6.2)
minitest (5.8.0, 5.4.3)
multi_json (1.11.2)
nokogiri (1.6.6.2)
power_assert (0.2.2)
psych (2.0.8)
rack (1.6.4)
rack-test (0.6.3)
rails (4.2.4, 4.2.3)
rails-deprecated_sanitizer (1.0.3)
rails-dom-testing (1.0.7)
rails-html-sanitizer (1.0.2)
railties (4.2.4, 4.2.3)
rake (10.4.2)
rdoc (4.2.0)
rubygems-bundler (1.4.4)
rvm (1.11.3.9)
sass (3.4.16)
sass-rails (5.0.3)
sdoc (0.4.1)
spring (1.3.6)
sprockets (3.3.1)
sprockets-rails (2.3.2)
sqlite3 (1.3.10)
test-unit (3.0.8)
thor (0.19.1)
thread_safe (0.3.5)
tilt (1.4.1)
turbolinks (2.5.3)
tzinfo (1.2.2)
uglifier (2.7.1)
web-console (2.2.1)
Eric Hanneken
Eric Hanneken
3,256 Points

A couple of things from that output stand out to me:

  1. gem list --local says that bundler is already installed.
  2. The warning about your $PATH.

Can you confirm that RVM's ruby and gem binaries are being executed?

which ruby

should say something like /Users/kaityhallman/.rvm/rubies/ruby-2.2.1/bin/ruby, not /usr/bin/ruby, and

which gem

should say something like /Users/kaityhallman/.rvm/rubies/ruby-2.2.1/bin/gem, not /usr/bin/gem.

If not, I think we should look in your ~/.bash_profile (or ~/.profile) to see how $PATH is getting set.

Eric Hanneken

this is what it says when inputting those commands

Kaitys-MBP:~ kaityhallman$ which ruby
/Users/kaityhallman/.rbenv/shims/ruby
Kaitys-MBP:~ kaityhallman$ which gem
/Users/kaityhallman/.rbenv/shims/gem 
Eric Hanneken
Eric Hanneken
3,256 Points

It looks like you have both RVM and rbenv installed, and they are probably in conflict. Since they do more or less the same things, it should be safe to get rid of one of them.

There is a script for removing RVM on this page. (Scroll down to "How do I completely clean out all traces of RVM from my system, including for system wide installs?") Note that you will still have to edit your ~/.bash_profile, ~/.profile, or ~/.bashrc files to remove the lines that the installation script inserted.

There are friendlier instructions for removing rbenv here, although you would still need to edit your bash dot files to delete the line rbenv init.

1 Answer

What was the exact command that you used? Also in one of the videos there is a link to a new updated tutorial that might work better.

just "gem install bundler"