Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

WordPress How to Install WordPress on Your Computer How to Install WordPress on Your Computer Installing WordPress with DesktopServer

Camie DeCovich
Camie DeCovich
20,287 Points

Getting 404 Not Found error when I click on the link in Desktop Server that goes to the Wordpress install script.

When working through the how to install WordPress with Desktop server video, I am getting a Not found error: The requested URL /wp-admin/install.php was not found on this server. The link is: http://wpdemo.dev/wp-admin/install.php I have researched my issue, but not finding an clear resolution. I can click on Sites link in desktop server and get the message "It works!" I am using a Mac 10.11.1 El Capitan and the Blueprint 4.2.2.zip that came with the DesktopServer download. Thanks.

3 Answers

Jason Anders
Jason Anders
Treehouse Moderator 145,855 Points

I'm not sure about Blueprint and/or Desktop server. I use MAMP and a local install of WordPress and everything seems to work fine for me. I have looked into Desktop Server, and I don't see anything that is better or easier than using MAMP.

Because you are on a Mac (Good choice by the way! :) Please check out Zac's course Local WordPress Development. He shows you how to use MAMP and a local install of WP.

Dear Camie or anybody having this issue,

I had the same problem but resolved it and my DesktopServer is working fine! The problem was that i had my MacOSX apache running over DesktopServer

To resolve this, just turn off your apache by typing the following in terminal

sudo apachectl stop

Then restart your DesktopServer

Hope this helps Cheers :)