Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

CSS Sass Basics (retired) Getting Started with Sass Installing and Using Sass

Getting error message in Ruby command prompt when I run "sass test.scss"

According to Hampton in the video, when I run "sass test.scss" nothing should happen. Instead I get

Errno::ENOENT: No such file or directory - input.scss Use --trace for backtrace.

I am using Windows 7 on an Alienware computer (if that helps). I saved the Notepad file in UTF-8 and I changed the prompt to Desktop where test.scss sits. Any suggestions? Thanks in advance for any help you can send my way.

Nevermind. Apparently problem was with how I was saving the scss file. Fixed it.

1 Answer

make sure your scss file is saved in the same directory that you'r trying to run sass test.scss from

Hi Paul,

Thanks for getting back on this one. I actually was saving it in the right file. However, I was saving it as a text file and not a scss file. I had to go into windows and turn off the hide extensions option in folder options. Then I could change the .txt extension to .scss. When I did that, sass could see the file. Thanks again for responding on it.