Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Development Tools

Git Code Challenge: Remote Work

Can somebody help me please? It's the first task and I'm really confused...

The Code Challenge says: Assume there's a git repository hosted at git://mygithosting.com/git_basics/cool_stuff.git. What command would you run to clone that repository?

I have tried (obviously not at the same time and without the quotes): "git clone -git://mygithosting.com/git_basics/cool_stuff.git", "git clone git://mygithosting.com/git_basics/cool_stuff.git", "git clone [git://mygithosting.com/git_basics/cool_stuff.git]"

I feel like I am extremely close but just missing a detail. :( Thanks in advance to anyone with input or advice!

4 Answers

It's simply git clone git://mygithosting.com/git_basics/cool_stuff.git

Odd that its not working for you. Refresh the page maybe? This command just takes the repo at that URL and downloads the repo .git folder directly to your local machine. Hope this helps :)

Thanks! I tried again this morning and I passed it! :)

can you post a link to the task please maybe I can help

Kevin Eudy
Kevin Eudy
6,874 Points

Can I hop in on this and get some help with the third task on the same challenge? I don't know if I'm misunderstanding the question or what but I've been stuck on it for two days and nothing I'm trying seems to be working. Thanks for the help.

git clone git://mygithosting.com/git_basics/cool_stuff.git just like Derick typed up top or you might be missing a colon or slash make sure its typed correct if need be copy and paste the code after git clone this should work. please let us know the outcome and if you need any more help

.