Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Development Tools

Aaron Cummins
Aaron Cummins
9,830 Points

Hard refresh

Chrome wouldn't let me do a hard refresh with command+shift+r. I clicked an option to disable cache and did a regular refresh but I'm still wondering two things. 1) Does that yield the same results? 2) Is there something wrong or some other way to make the hard refresh work?

3 Answers

Hi Aaron!

I have sometimes had to go into Settings > Privacy and Security > Clear Browsing Data to clear the cache before a hard refresh will act as expected (when using Chrome).

Also, I have found that if I enable a CDN (Content Delivery Network) on a site, sometimes a change to the website (such as swapping-out an image) won't take effect, even with a hard refresh, because the change hasn't propagated through the CDN (can take hours to days, sometimes). In fact, I will usually disable any CDN while developing, to avoid such issues.

By the way, if you are using anything like WordPress, it helps to use a plugin, such as WP Super Cache, to completely clear your cache and be able to hard-refresh properly.

More info:

https://stackoverflow.com/questions/25958420/chrome-wont-clear-cache-ctrl-f5-doesnt-seem-to-work-either

I hope that helps.

Stay safe and happy coding!

Aaron Cummins
Aaron Cummins
9,830 Points

Thanks, definitely was a separate issue but this is great to know for future reference!

Aaron Cummins
Aaron Cummins
9,830 Points

I figured out that it was actually another app called 'Be Focused' that was running in the background and had overridden the key shortcut.

Glad you found a solution!

Have a great weekend!