Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Drew Konopasek
Drew Konopasek
5,055 Points

Help with Active Record Basics

Hampton Catlin

I am trying to follow along on the Migrations Video under Active Record Basics. Unfortunately I am getting some errors that I have searched all over the Internet and cannot seem to figure out what the issue is. When I type in the command

rake db:create I get

rake aborted! LoadError: dlopen(/Users/drewkonopasek/.rbenv/versions/2.0.0-p353/lib/ruby/gems/2.0.0/gems/mysql2-0.3.16/lib/mysql2/mysql2.bundle, 9): Library not loaded: @@HOMEBREW_PREFIX@@/opt/openssl/lib/libssl.1.0.0.dylib Referenced from: /usr/local/lib/libmysqlclient.18.dylib Reason: image not found - /Users/drewkonopasek/.rbenv/versions/2.0.0-p353/lib/ruby/gems/2.0.0/gems/mysql2-0.3.16/lib/mysql2/mysql2.bundle /Users/drewkonopasek/biller/config/application.rb:7:in <top (required)>' /Users/drewkonopasek/biller/Rakefile:4:in<top (required)>' (See full trace by running task with --trace)

I also try to run mysql -u root and I get

dyld: Library not loaded: @@HOMEBREW_PREFIX@@/opt/openssl/lib/libssl.1.0.0.dylib Referenced from: /usr/local/bin/mysql Reason: image not found Trace/BPT trap: 5

I run brew doctor and it tells me

You have an outdated version of /usr/bin/install_name_tool installed. This will cause binary package installations to fail. This can happen if you install osx-gcc-installer or RailsInstaller. To restore it, you must reinstall OS X or restore the binary from the OS packages.

Is this the reason why my commands aren't working? I have tried pretty much everything I have found on the Internet and really want to keep moving forward but I am stuck here until I figure this error out. Thank you.

1 Answer

Have you tried uninstalling then re-installing the software. I'm fighting with migrations as well right now.