Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby Ruby Collections Ruby Arrays Ruby Arrays

How can I type square brackets in workspaces on a german keyboard using Mac?

Hello Treehouse Team and community.

I have a problem: I am not able to type square brackets in the ruby workspace console with the german keyboard configuration. I am using a Macbook Pro, and normally on a german keyboard, the [] are typed in with ALT 5 and ALT 6. This does not work in the console of the ruby workspace.

I changed my keyboard to English and then I could type them, but since I am used to the german keyboard, this is not a good workaround for me.

I hope there is a solution for this problem, so I can get on with the ruby course using my german keyboard. :)

So does anyone know how to type square brackets on a german mac keyboard in the ruby workspace console?

Greetings, Anna

Britta Reinbold
Britta Reinbold
523 Points

Hey Anna, I had the same problem today (looking for the square brackets and couldn't find them) but it seems they fixed it and you can type it within workspaces with the normal shourtcut you are used to.

Nevertheless there are still problems occur with the german keyboard: does anybody know how to indent several lines of code? It's recommended to use CMD+square bracket and taaaaadaaaaa....next issue ;)

10 Answers

Didn't worked for me... I guess Treehouse needs a bit internationalization ;-)

I am using the mac terminal....

Hi Cena,

on a german keyboard the square brackets are hidden, I guess that's what you mean by missing. You don't see them on the keys. You can type them using "ALT" and "5 " / "ALT" and "6".

Maybe I can change some keys, but this would still get confusing sometimes. Would be best, if I didn't have to change anything.

Immanuel Jaeggi
Immanuel Jaeggi
5,164 Points

I found the square brackets on a german keyboard, by changing the keyboard to ABC/Extended and hitting the ΓΌ and the + keys. I use a Mac.

Viraj Kokane
Viraj Kokane
17,531 Points

You might need to press "Option" + "5" or "6" ! visi this link for help: https://discussions.apple.com/thread/1444246?tstart=0

Viraj Kokane
Viraj Kokane
17,531 Points

Hi Jens Geffken! You can also ask the Support Team for help if you need!

Thanks for all your answers, but the problem still remains, I can't type {} or [] with my german keyboard in the workspace. I will go on and use my mac terminal now, too. This works fine :)

Still it would be great of Treehouse to solve this problems, there might be more people with german keyboards having this problem using workspaces.

Hi Anna,

Out of curiosity, are the bracket keys missing on the German keyboard?

I wonder if you could try remapping a couple of less commonly used keys to the the square brackets (instead of changing the entire layout to English.)

Best, Cena

Immo Struchholz
Immo Struchholz
10,515 Points

For anyone who still has this problem: I greatly advise switching to the US qwerty layout when programming. All of the special characters are easily accessible that way. Adding, and switching between, keyboard layouts is easy, no matter what OS you are using. I used to use the german qwertz layout myself for a long time, but it was always a struggle when programming.

Hello,

i am currently struggling with the same problem. I am doing the ruby courses and i cannot type {[ in the terminal(workspace). Does anyone have a fix for this? I am not a Mac user. Thanks!

Right Mouse click...

right mouse click?