Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript

James Page
James Page
9,621 Points

How do I permanently prevent Chrome from disabling 'unsafe scripts'?

For example, it prevents the Workspaces window from loading its dependent JS scripts, so each time a Workspace window is launched I have to enable the scripts and reload the window.

1 Answer

Hey James Page,

Try going into your settings and look for the button that says "Content Settings" under the Privacy section. In there, there is a JavaScript section which allows you to either "Allow all sites to run JavaScript (recommended)" or "Do not allow any site to handle protocols". It sounds like you may have that second option marked right now. I hope that helps!

James Page
James Page
9,621 Points

Hi Marcus,

That section is already enabled.

It's not that the browser is blocking all JS - it's just blocking some (which Chrome deems 'unsafe') whilst allowing other scripts.

I should mention that I've tried using the solution mentioned here: http://superuser.com/a/487824/98276 - but the 'load unsafe scripts' 'feature' remains.

Hmmm, you might try disabling Chrome's phishing and malware protection. That's the only other option I can think of and that option is underneath the Privacy section, as well. Might I ask what scripts you are running?

James Page
James Page
9,621 Points

Might be worth a try.

I'm not trying to run any of my own scripts - it's scripts that the Workspaces feature is trying to run. Similar happens with other sites (e.g. the Pocket bookmarklet on various sites). It's more of a hindrance than a help.

Do you have any extensions running in your browser? And have you updated to the latest version of Chrome? Honestly, Chrome is the main browser I use to get on Treehouse, and I haven't had any issues with it like you're seeing. There has to be something else going on that we're not seeing, I think. lol

James Page
James Page
9,621 Points

I'm running a few extensions. I could disable them. Intuitively, if any of them are causing an issue, I'm guessing it would be something like uBlock.

Yea man, you may have accidentally added a filter to ublock for those sites. Maybe before you just disable it, you should see if you can see what filters are active under the extension right now and delete any filters that don't belong, if you've been adding filters to other sites, but if you haven't, maybe just purge ublock's settings and reset it back to default. I just briefly took a look at the extension, but it seems to operate under a filter policy like that.