Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Java Build a JavaFX Application Build a Pomodoro App Explore Existing Code

How do i run the main?

I dont know if this is starring right in my face but i cant seem to run the pomodoro project, I have searched all over google for the answer and none of them seem to work.

These are the error messages i recieve:

Information:java: Errors occurred while compiling module 'pomodoro-project' Information:javac 1.8.0_141 was used to compile java sources Information:14/08/2017 11:33 - Compilation completed with 1 error and 0 warnings in 1s 410ms Error:java: invalid source release: 1.9

  • I have tried to use Eclipse compiler
  • I have tried to change the project bytecode
  • I have tried to change the SDK

I assuming its something to do with the version i am using but i cant find a solution anywhere

Does anyone know how i get this project to run?

1 Answer

I found the solution. To anyone else with this issue, here is how i resolved it.

First check the Java Compiler

  • File - Settings - Build, Execution, Deployment - Compiler - Java Compiler

Check that the Project bytecode version is set to 1.8 or lower

Secondly, check the Porject SDK and language level

  • File - Project structure - Project

Check that the project SDK is set to 1.8 or less and the Porject language level is set to SDK default.

Thirdly, check the source language level

  • File - Project structure - Modules - Sources

Check that the language level is set to Project default (I believe this may have been my issue but its goodd to check the others anyway)