Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Python Introducing Lists Using Lists Iteration

How to enable extensions for python in visual studio code?

You're taking a good step on your Python journey by including a professional class integrated development environment like VSCode, PyCharm, etc.

If you enable the "Python extension for Visual Studio Code" written by Microsoft you can do breakpoints and examine the values of variables etc.-- something you can't do directly with "python -i"

I was just given this as an answer to previous question but how do I enable python extensions in VS, I assumed it was working ok because i've been programming with python in VS already?

1 Answer

Travis Alstrand
seal-mask
.a{fill-rule:evenodd;}techdegree seal-36
Travis Alstrand
Data Analysis Techdegree Graduate 45,972 Points

Hey there jas0n !

As far as I'm aware, if you go to the extensions tab on the left side of the screen, then click on the Python extension, there should be three options underneath the title: "enable/disable", "install/uninstall" & "switch to pre-release version".

As long as it's showing "disable" as an option, that should mean that it's enabled. But always be sure to scroll down the page for extensions as sometimes there's further steps you need to take within the VS Code settings/preferences to get certain extensions to work as expected.

For example, when I first started, I had the "Prettier" extension installed for the longest time and never noticed anything. It wasn't until I read through that page and realized I had to go into the settings and set it as my default formatter that it would take any effect :smile:

I hope this helps you out!