Ruby Ruby Foundations Hashes Creating Hashes

I am having trouble installing Awesome Print on my Ubuntu operating system.

I am having trouble installing Awesome Print on my Ubuntu operating system. I "sudo gem install awesome_print" just fine, but when I went into the IRB to require it, it returns a "==>false" to me everytime. Could someone please help me?

1 Answer

Milo Winningham
STAFF
Milo Winningham
Treehouse Staff

What happens when you try to actually use Awesome Print? This doesn't sound like an error to me.

The Ruby documentation says that require returns true if the file was loaded for the first time, or false if the file was already loaded. If Ruby couldn't find the file, you would get a LoadError.