WordPress Installing WordPress Locally Installing WordPress Locally Setting up the Environment

random Joshua
random Joshua
136 Points

I cannot get into phpMyAdmin

It says: phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

I have checked the host, username and password, they are correct.

Besides, there is no greenlight in front of "MySQL Server" in the panel of MAMP.

4 Answers

Liam Clarke
MOD
Liam Clarke
Treehouse Moderator 19,204 Points

Yes all makes sense when you mentioned you are using a VPN, and seeing you don’t permissions.

It totally depends what your actually doing with MAMP, but your vpn will send all traffic through the proxy so when you go in mamp the users don’t match up.

There is a potential work around, in my current job we set our proxy’s in our environmental variables to work through the proxy, you could possibly try the same although I’m not sure if it will have the same affect with a VPN.

Glad it’s sorted though!

Alexandra Cianciara
Alexandra Cianciara
2,465 Points

How could I resolve this? Having the same issue. The issue is where I go from MAMP application and go to WebStart page: http://localhost/MAMP/?language=English

The page is being blocked and it says to check connection and proxy and firewall settings. The site cannot be reached.

Because of this I cannot even go to Mamp Admin settings.

Please could someone help me.

Liam Clarke
MOD
Liam Clarke
Treehouse Moderator 19,204 Points

Hard to tell without seeing the log file but there are a number of reasons for this.

Before you do any of this, back up your files:

Stop mamp running

If you have another mysql service running, stop them running or change mysql port.

if that doesnt work, the log file could be corrupted, go to your mamp directory "MAMP\db\mysql" and move the 2 log files from the folder (Dont delete them, just move them) and restart the server, if that doesn't work put the log files back

I would probably reinstall if none of the above work

random Joshua
random Joshua
136 Points

I have tired the method you provided, but it doesn't work, Do you need any more information to confirm the problem?

As for reinstall, I reinstalled before, but it didn't work.

Liam Clarke
MOD
Liam Clarke
Treehouse Moderator 19,204 Points

There is an error log file which may hold some information which is loacted : "MAMP\logs\mysqp_error_logs"

Can you try:

open the task manager > Performance tab > Open Resource Montiror (at the bottom) > Network tab > Listening Ports

And make sure the port your running mamp on is not being used, I believe default is 3306

If there is nothing running at 3306, start MAMP again and let me know what you see in the listening ports, you should have 2 mysql exe applications

random Joshua
random Joshua
136 Points

i've try the way you told me, but there is no 3306 in the Listening port, of course i have made sure mysql in using port 3306 and 3306 is not being used.

As for the mysql_error_log.err file, i've upload to google document, here is the link: https://docs.google.com/document/d/1yA3EE5Oho1EpxmuY1Gu1FO9wryMxaTpCe_F0cmM4EAA/edit?usp=sharing

Hope that could help you locate the problem.

There is another thing that i don't know if it is vital: When i switch on the server, a window would pop out and says: ‘APACHE' needs open port 80 which is already used by httpd. But in the panel of MAMP, APACHE server has a greenlight so i think it may not be the problem

Thank you very much for your help!

Alexandra Cianciara
Alexandra Cianciara
2,465 Points

Hi Liam, I tried this and I have httpd.exe running on 8888 which is my port. When I stopped servers on mamp, it disappeared and when I restarted it I came back so I think this is for Mamp. I don't have 3306

Liam Clarke
MOD
Liam Clarke
Treehouse Moderator 19,204 Points

in your task manager can you quit httpd before restarting mamp too.

The issue is with your mysqld.exe file, can you go to "D:\MAMP\bin\mysql\bin\" and check that you have a "mysqld.exe" file there.

If you do have that file:

Check that you have the correct permissions, you're getting Errcode: 13 - Permission denied, this is probably due to having permissions set up by a different user, MySQL cannot read some of the logs or it is trying to find a file that doesn't exist.

for the user, I would just recommend a complete remove and re-download

for the MySQL can't read logs and try to find a file that doesn't exist, check that you dont have any proxy settings or antivirus blocking it from executing.

If you don't have that file:

your mamp is corrupted and you will have to completely uninstall and remove and re-download the latest.

If none of the above works, I'm afraid I don't know what it could be.

random Joshua
random Joshua
136 Points

Thank you so much for your generous help.

Fortunately, i have mysqld.exe. But i can't find out where the "different user" is, do you mean there is another programme also using mysqld.exe?

Besides, i do use VPN when i open MAMP, which means i am using proxy. I shut down VPN, but it doesn't work.

I will try to reinstall MAMP, but i doubt if it works, after all i tried before.

So I stuck again QAQ, thanks again for your help.


reinstall MAMP and shut down VPN before using it. It works! Thank you so much for your Help!

So it mean that I should shut down VPN before using MAMP? Would it be possible that the proxy still occupies some port after I shut down VPN?

Thank you again for your helping