Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


I cannot launch Android Studio!

when launching studio64.exe as administrator I get a pop up stating : "Failed to load JVM DLL C:\Program Files\Java\jdk1.7.0_67\jre. If you already have a 64-bit JDK installed(which I do), define a JAVA_HOME variable in Computer > System Properties > System Settings > Environment Variables. (Which I already have done)" I have set the variable as so ; Variable name : JAVA_HOME Variable Value : C:\Program Files\Java\jre7

The target value is the exact location where my jre7 folder is stated yet I still get the error message along with "The program can't start because MSVCR100.dll is missing from your computer" Please help!!

Peter Gordon
Peter Gordon
2,473 Points

Your JAVA_HOME should be set to the location of your JDK e.g. C:\Program Files\Java\jdk1.7.0_67. Secondly, are you launching from the Start Menu or from the install location? Make sure the shortcut is correct.

Failing that, you can update your Microsoft Visual C++ 2010 Redistributable Package (x64).

Thanks Peter Gordan I had to update my Redistributable Package, everythings working smoothly now, thanks.

2 Answers

I know you are setting them in system properties, but there are both USER and SYSTEM variables in there. Most documentation forgets to specify whether it needs the SYSTEM on or the USER one set, so try setting both. Also, make sure the variable is not set twice by separate statements. I have not messed with this in a long time but I did write a similar answer to this question several months ago. It can be a pain to install on Windows.

Daniel Muchiri
Daniel Muchiri
15,407 Points

I had the same problem. Everything works after I installed Microsoft Visual C++ 2010 Redistributable Package (x64). Thank you.