Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP Building Websites with PHP Slim Basics & Twig Templates Including & Rendering

Jason Ho
Jason Ho
1,509 Points

I can't upload any files. Whenever I click upload files, nothing happens.

Already downloaded the zip file and extracted everything. Ready to be uploaded into the document except I can't access it because the upload file button doesn't seem to work.

3 Answers

Ry Belisle
Ry Belisle
5,780 Points

Yeah, I ran into the same issue on my version of Firefox. Not too sure on what the issue is, but if you want to just grab the files for your workspace, run the following command in your console:

git clone https://github.com/treehouse/emerson.git

Which will clone all of the files needed into an "emerson" directory on the server that you can use whenever you need them. Just right click the left-side directory listing, select "refresh", and you'll be able to see/move those files.

The simplest way to get this done is to simply click, drag, and drop your files from your file explorer to the workspace. You'll see a little box appear in the bottom left of the workspace that says something to the effect of, "Drop files here to upload".

Lukas Smith
Lukas Smith
4,026 Points

What You want upload ? From computer to server using FTP ? or you have application running on server and you try upload file for example like profile photo ? it could be problem with directory rights. Change chmod 777 and try again