Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Development Tools HTTP Basics Introduction to HTTP HTTP Requests Using Telnet

I do not see what I type into Windows Command Prompt

Hi all, I am using Windows 10 I type telnet httpbin.org 80 into command prompt and it connects. New window opens and then I type in GET /xml HTTP/1.1 , Host: httpbin.org , but as I am typing I can not see what I am typing. I get the results but , as I am typing I can not see what I am typing. If somebody could help.

Thank you

5 Answers

Test Test
Test Test
21,581 Points

Hi! 1) Open command prompt -> 2) type "telnet" -> 3) type "open httpbin.org 80" (make sure to type the word "open"). After that your GET command or whatever you type will show in the top left corner, overwriting text that's already there. If it does not work then type "set localecho" between steps 2) and 3).

Hi Jennifer, thank you for your answer but as I start typing it closes connection, saying 400 Bad request.

Hi Darko,

I was having the same problem and eventually tried enough combinations and it worked. Jennifer and Konstantin are correct (kudos to them for coming up with the solution!).

After entering "telnet" in the console type the 'set localecho' command as the other posters suggested.

set localecho

This command will cause the text you type to appear in the upper left corner of the screen (over top of text already in the console window - makes the text difficult to read...). Once you get to this stage type the commands as shown in the video:

GET / HTTP/1.1
Host: httpbin.org

Hit 'enter' twice after the last command and you should get the result as shown in the video

Jennifer Nordell
Jennifer Nordell
Treehouse Teacher

Take a look at this from Microsoft. I still feel like the answer lies in the localecho which is shown under the display command. https://technet.microsoft.com/en-us/library/c.aspx

i cannot connect . After i type open httpbin.org 80 i see connecting to... then after is finally connected anything i type leads to connection lost

Microsoft Telnet> open httpbin.org 80 Connecting To httpbin.org...

Connection to host lost.

Test Test
Test Test
21,581 Points

Solution #1: open command promt as admin (right click on the icon -> launch as admin). It will work and connection won't be lost. After that every other session will work too, so you don't have to launch it as admin everytime. Solution #2: just type "telnet httpbin.org 80". It won't display what you type but connection will be stable.