Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP

I dont have homestead.yaml file after instaling laravel homestead..http://prntscr.com/5mdlif Can someone help me?

I watched tutorials and I done same as it is in those lessons but when I open homestead folder there is no homestead.yaml file at all.. I am using windows 7,and I have watched homestead installation for windows but as I said,cant solve what cause the problem..

12 Answers

i tried buy it wont work.. http://prntscr.com/5merzf

Miguel Angel Rodriguez
Miguel Angel Rodriguez
11,280 Points

Now you have to type bash init.sh And the Homestead.yaml file is locate in src/stubs/ folder

Stone Preston
Stone Preston
42,016 Points

looking at the homestead docs you need to run the following command

homestead init

that will create the homestead.yaml file.

it looks like homestead has changed a bit since this course was released. the yaml file belongs in the ./homestead directory now. so run the init command and make the necessary changes to the file that gets created

i did it as it is written here Once you have installed the Homestead CLI tool, run the bash init.sh command to create the Homestead.yaml configuration file: It shows homestead initialized but still it is not showing yaml file :/

when it shows "homestead initialized" that's already great. so with the new Homestead configuration the Homestead.yaml file is placed in your home directory in a hidden directory called .homestead. doing the following (line per line) in the terminal should get you the the Homestead.yaml file:

cd $HOME
cd .homestead
nano Homestead.yaml

Now you can edit the file.


NOTE: After you executed ...

cd .homestead

you can check whether the Homestead.yaml file is listed in that directory by executing

ls

Hope that helps you.

thanks for the answer but something is still wrong.. :/

http://prntscr.com/5qg3io

you didn't execute the first two commands after Homestead got initialized, so after Homestead got initialized do the following:

1.) cd $HOME

then

2.) cd .homestead

and then

3.) nano Homestead.yaml

yes,I tried..it shows nano as unknown command..but anyway now I see that .homestead folder in home dir..but why is it separated from created homestead folder couple steps before?shouldnt it be in it(,homestead files in homestead folder),if u understand what I wanna say :D

jap, i know what you mean, thought of that too. this might have happend with some of the latest Homestead updates. but great, if you find the the .homestead folder, you can also use your prefered text editor to edit the file (nano is also just a terminal text editor).

but now I have two folders,,one is .homested with this in it http://prntscr.com/5qygch and second one is homestead with this in it http://prntscr.com/5qygqc Shouldnt they be merged in one folder after..why is it separated here ? :/

that's the way Homestead is structured now, better don't merge. That'd need some other adjustments too. You can see the .homestead folder as the folder including configuration and the Homestead folder (in your server root) as your working folder to i.e. start vagrant.

First of all you need to go in the homestead folder via cmd

cd Homestead

after you can create a Homestead.yaml

// Mac / Linux... bash init.sh

// Windows... init.bat

This command will create homestead.yaml file in you Homestead folder Thank you