Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

iOS Implementing Designs for iPhone Implementing Custom Login and Sign Up Screens Getting up to Speed

i downloaded Ribbit project but I keep getting a "build fail" when trying to run controllor in xcode. can you help?

error list:

ld: warning: ignoring file /Users/jgawlik/Downloads/Ribbit/Parse.framework/Parse, missing required architecture x86_64 in file /Users/jgawlik/Downloads/Ribbit/Parse.framework/Parse (3 slices) Undefined symbols for architecture x86_64: "OBJC_CLASS$PFFile", referenced from: objc-class-ref in CameraViewController.o "_OBJC_CLASS$PFObject", referenced from: objc-class-ref in CameraViewController.o "_OBJC_CLASS$PFQuery", referenced from: objc-class-ref in InboxViewController.o "_OBJC_CLASS$PFUser", referenced from: objc-class-ref in SignupViewController.o objc-class-ref in LoginViewController.o objc-class-ref in InboxViewController.o objc-class-ref in EditFriendsViewController.o objc-class-ref in FriendsViewController.o objc-class-ref in CameraViewController.o "_OBJC_CLASS$_Parse", referenced from: objc-class-ref in AppDelegate.o ld: symbol(s) not found for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation)

2 Answers

Jakub Golan
Jakub Golan
Courses Plus Student 28,393 Points

Hey Peter I haven't run into this issue myself, but after googling your error I found this from another user on this forum who was having a similar issue.

I don't know if you have fixed it yet but i ran into the same error. It turns out i just hadn't imported the Bolts.Framework I got in the Parse asset file. Hope that helps!

Hope it helps.

Cheers, Jakub

Thank you! I am quite new to this. Do you have any resources that explain how to import Bolts.framework into my project?

Jakub Golan
Jakub Golan
Courses Plus Student 28,393 Points

:) I never ran this course, so I don't have any personal experience with this project, but I found this site which seems to be a good place to start:


These are the instructions they give for getting Parse framework working:

To make the Parse headers available in Swift code, you have to provide a special header file. The header file bridges the framework into the Swift universe.

Create a new header file in Xcode (Xcode -> New file -> Header file) and name it <project-name>-Bridging-Header.h. It’s important that <project-name> matches the actual name of the project.

Add the import statements for the Parse.com framework like this:

#ifndef _lillygram__lillygram_Bridging_Header_h
#define _lillygram__lillygram_Bridging_Header_h

#import &lt;Parse/Parse.h&gt;
#import &lt;Parse/PFObject+Subclass.h&gt;
#import &lt;Bolts/Bolts.h&gt;


Let me know if this solved your issue and just as a tip anytime you are really stuck Google (or Stack Overflow) is your friend :)