Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP

I figured out how to set up and use the identical installation as this lesson. People seem to have a trouble with this.

Students seem to have a trouble with following the lesson because users for the latest packages need to program very differently than how this lesson teaches. The best way is to simply install the (older) versions of packages that this lesson uses. The easiest way is to make sure you have the following for "require" in the composer.json:

    "require": {
    "monolog/monolog": "~1.13",
    "slim/slim": "~2.6",
    "twig/twig": "~1.18",
    "slim/views": "0.1.*"
}

and in terminal: composer install. This will install all the packages with the specified versions.