Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby Build a Todo List Application with Rails 4 Build a Todo List Application with Rails 4 Generate a Scaffold

I get an error message whenever I try to generate a scaffold for the todo list

Sorry for the wall of error messages.

Whenever I try to run the command "bin/rails generate scaffold todo_list title:string description:text" I get this error message.

I am using a cloud based IDE, could that be the problem?

/usr/local/rvm/gems/ruby-2.1.5@global/gems/bundler-1.7.6/lib/bundler/runtime.rb:34:in block in setup': You have already activated spring 1.3.6, but your Gemfile requires spring 1.3.4. Prependingbundle execto your command may solve this. (Gem::LoadError) from /usr/local/rvm/gems/ruby-2.1.5@global/gems/bundler-1.7.6/lib/bundler/runtime.rb:19:insetup' from /usr/local/rvm/gems/ruby-2.1.5@global/gems/bundler-1.7.6/lib/bundler.rb:121:in setup' from /usr/local/rvm/gems/ruby-2.1.5@global/gems/bundler-1.7.6/lib/bundler/setup.rb:7:in<top (required)>' from /usr/local/rvm/rubies/ruby-2.1.5/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:128:in require' from /usr/local/rvm/rubies/ruby-2.1.5/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:128:inrescue in require' from /usr/local/rvm/rubies/ruby-2.1.5/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:39:in require' from /usr/local/rvm/gems/ruby-2.1.5@rails4/gems/spring-1.3.6/lib/spring/commands.rb:33:in<module:Spring>' from /usr/local/rvm/gems/ruby-2.1.5@rails4/gems/spring-1.3.6/lib/spring/commands.rb:4:in <top (required)>' from /usr/local/rvm/rubies/ruby-2.1.5/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:inrequire' from /usr/local/rvm/rubies/ruby-2.1.5/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:in require' from /usr/local/rvm/gems/ruby-2.1.5@rails4/gems/spring-1.3.6/lib/spring/server.rb:9:in<top (required)>' from /usr/local/rvm/rubies/ruby-2.1.5/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:128:in require' from /usr/local/rvm/rubies/ruby-2.1.5/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:128:inrescue in require' from /usr/local/rvm/rubies/ruby-2.1.5/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:39:in `require'

1 Answer

Aaron Kaye
Aaron Kaye
10,936 Points

You can specify the version of spring in your Gemfile. Not sure what the root cause is but I am guessing it is just a mismatch in current spring version vs used spring version:

gem 'spring','~>1.3.6'

That seemed to work! Thanks so much!