Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby

i got a problem with "gem install rails"

i get an error but no gems installed. it just goes straight to an error

ERROR: while executing gem... .. (NoMethodError) undefined method size for nil:NilClass

ive been trying to figure this out for the past couple hours and nothing!

This is one of the hardest things to debug. Especially not being in front of the computer.

What steps have you done so far?

Likes sites installed from?

4 Answers

gem install bundler worked fine. i found out from another video i have opened up that i have to type in . . gem install rails --version=3.2.18, and it installs all the gems but now when i type in "cd Document" than type "rails new testapp" it shows a lot but at the bottom it says please use fiddle

im following this video on how to install for windows and i got everything right up until the 4:55 mark when he types "gem install rails" than i get that error message

https://teamtreehouse.com/library/installing-a-ruby-development-environment/installing-a-ruby-development-environment/installing-ruby-on-windows

Did you close and reopen your terminal after install just to make sure?

yup

Can you install any gem? Have your tried to install bundler? gem install bundler

ok so that was the issue. i had to type in gem install rails --version=3.2.18 and it gave me everything..