Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS Build a Playlist Browser with Swift Building the Master and Detail Views Connecting UI to Code

Rogelio Valdez
Rogelio Valdez
6,244 Points

I have Spanish keyboard so for cmd + = shortcut I need to press cmd + Shift + 0 and this takes me to documentation. help

the computer assumes I want to press cmd + shift + 0 instead of cmd + = note: my = (equal) symbol is in the 0 (zero) key.

this has happened with other shortcuts but still works when there is no shortcut that includes shift o alt or the other key I need to press to get the symbol I need typed.

Do any of you guys knows a way to get around it? stick keys or something to let the computer know I'm pressing shift for the symbol = not for the shift key itself.

Ethan Roode
Ethan Roode
6,674 Points

I think the best thing to do in your scenario is to order a new keyboard, or keys for your laptop idk. And go to Preferences>Keyboard>Input Sources and then add an english keyboard, and assume the keys as shown. Good luck

Andrés Leal
Andrés Leal
9,563 Points

What I do is go to: Editor>Size to Fit Content, that works for me (I have the spanish keyboard) Hope that helps

1 Answer

David Pena Abad
David Pena Abad
16,288 Points

Hi Rogelio,

I have a Spanish keyboard too, the best way to solve this problem is to go to the toolbar and to search XCode>Preferences>Key Bindings. In this menu, you must write "Size To Fit Content" in the search tab and click over the code "command + equal" to change it for "command + control + equal", since this instruction doesn't have any conflict with other shorcuts.

See you soon