Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress WordPress Theme Development Custom Post Type Templates in WordPress Coding Your Own Custom Post Type Templates

I have trouble uploading my pictures

Hi there, I have trouble uploading my pictures. I keep getting an error message (an error occurred in the upload. please try again later) and the upload never reaches completion. Its important to say that I am following the procedure as shown through the lesson’s video and therefore I cannot really identify the reason that the photo uploads keep failing.

All my pictures are under 6Mb as asked.

Thank you

3 Answers

Sue Dough
Sue Dough
35,800 Points

Deactivate all plugins and see if it works. If it does, then re-activate plugins one-by-one to you find out which one is causing it. If its not a plugin issue then I would also check your php.ini file and find out your max upload size.

Hi Maria,

Although the file size is under 6mb, are the actual image dimensions still quite large as this could be causing the upload error?

Here's a WordPress support topic post from someone who appeared to have the same issue but found that the dimensions were the cause (larger than 1000px x 1000px).

Hope that helps.

-Rich

Hi there guys and thanks for the help but nothing seems to work. I can't tracked donw the php.ini file and I have tired uploading pictures that were really small in size and still get the same error. All these when I use XAMPP whilst everything seems to work when I use FileZilla.