Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

WordPress Build a Website with WordPress Customizing WordPress Themes Customizing WordPress Theme Files

I keep getting a 500 Error Reading: "Internal Server Error

Error reads: "Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@demo-lms.co.za to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request."

PS. the 500 Error only comes up when I try and view the 'Sample Page'.

2 Answers

Rich Salvucci
Rich Salvucci
16,716 Points

Try resaving the permalinks in the settings.

I usually get this if there's a error in my php code in a template file. If you've got access to the server logs, check out the php error log and it should tell you which file and which line the error is on.

If not, you could try removing all of the php code from the body of the template file being used by the sample page and see if it loads then. If it does, start adding the php functions back in one by one, refreshing the page each time until you find the one causing the error. Once you know where the problem is you'll find it easier to find a solution.

Thank you Alan.

I ended up just having to reset the Permalinks :).

Much appreciated.