Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript Gulp Basics Welcome to Gulp.js Installing Gulp

Jonathan Grieve
MOD
Jonathan Grieve
Treehouse Moderator 90,956 Points

I think Gulp is installed. but I'm not sure what these warnings mean

So I went through the process of installing Gulp and I reckon it's installed....

if I type gulp -v into Git Bash i get this

$ gulp -v
[16:14:31] CLI version 3.9.1
[16:14:31] Local version 3.9.1

But in the midst I got some strange looking warnings. when i was installing the npm projects and dependencies.

$ npm install -g gulp
npm WARN deprecated graceful-fs@3.0.8: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible
. Use 'npm ls graceful-fs' to find it in the tree.
npm WARN deprecated lodash@1.0.2: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^4.0.0.
npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.

Anyone know what these mean and how I can fix them? Thanks :)

1 Answer

akak
akak
29,445 Points

Hi,

It looks like Gulp uses dependencies that are deprecated. It's a warning and everything should work just fine. Gulp itself has to update dependencies it relays on. Nothing you can do about it on your side. graceful-fs started to give a lot of warning in many projects lately. But as you can see it's about a future release. The message itself states that it won't work when node 7 cames out. Right now we have 6.2 so we're quite safe :)

Bottom line: ignore it :)

Cheers!

Jonathan Grieve
Jonathan Grieve
Treehouse Moderator 90,956 Points

Okay cool! :)

But how do I update when the time comes?

Maybe npm update? npm update gulp? Thanks :)

akak
akak
29,445 Points

I would suggest to do

npm install david -g  #add sudo on mac/linux 

It's a great package update app. Then from time to time

 david --global 

to check if you have outdated global packages. If that's the case you do

david update --global #add sudo on mac/linux

In my experiance it works better than internal npm "update" command that sometimes doesn't work as it supposed to :)

EDIT: You can of course specify that you want to update only Gulp.