Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


I Tried to use a different picture from the web instead of the smiley icon, but it fails to load the new image.

I was able to load the mipmap with a .png picture I downloaded from the internet. I can further go into each ic_launcher.png double click them and see the picture I want. Next I try to run the program which runs fine but does not have the new image in the icon. (Has whatever the last one I loaded was, so still the face icon that it had us build in the video)

Video: How to build a simple Android App, Adding an App icon.

Maybe helpful debug info: 2:01:47 PM Gradle build finished with 1 error(s) in 1s 187ms (event log) 01-07 14:02:29.963 2694-2709/---.firstprogram E/Surface: getSlotFromBufferLocked: unknown buffer: 0xab855f50 (Android Monitor)

OS and Software info: Currently running on Windows 10 with Android Studio updated to latest.

Did you save android studio before running it?

Yes I saved it, I ran it the same way I ran the tutorial one which came as an attached zip from the teachers comments which I was able to get to work. Only difference I can see is the one in a tutorial had all the different formats hdpi mdpi xhdpi etc, where as the one from the internet that I can't get to work only had 1 size which I shoved into all the different formats.

Did you save it as "ic_launcher.png"?

Yes I saved it as ic_launcher.png and overwrote all the different mipmaps with my picture from the internet