Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

HTML Build a Blog with Jekyll and GitHub Pages Getting Started with Jekyll Installing Jekyll

Seth Kroger
Seth Kroger
56,413 Points

If 'jekyll -v' gives you the error "cannot load such file -- jekyll/version" try 'gem cleanup'

Putting this fix out there for anyone who gets the same error I did after installing.

4 Answers

This also helped with the jekyll: command not found issue I was tearing my hair out over.

Thanks Seth!

Guil Hernandez Stu Cowley Seth Kroger Doesn't work for me; for problems like this, it's probably going to require adding jekyll to the user's preferred command prompt (zsh, bash, fish, & etc).

This is unfortunately a common problem if users use rbenv, rvm & so on because jekyll way of installing with environments with these Ruby managers has quirks most novices of such tools will not be able to debug intuitively.

This is what I generally do for rbenv for example. Solve command not found for jekyll with most rbenv setups

I couldn't get Jekyll installed either, but I didn't see any error. In fact, my terminal returned successfully installation even though "Jekyll -v" remained unrecognizable command for my environment.

Here are processes/tricks I tried to get Jekyll installed:

  1. gem update
    //this step could really take a "while", approx. 2-3 episodes from Treehouse Friend, even though respectively speaking, I doubt the necessity for this step.
  2. install rbenv and Jekyll //ref. https://talk.jekyllrb.com/t/cant-run-jekyll-on-mac-os-x-10-11-el-capitan/1284/2