Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Simple Android App with Java Creating the Screen Layout Setting Colors

I'm pretty sure of my answer!!!!

at least you can you can show the right answer so I can continue the next video! I'm stuck now, I don't want to wait.

activity_main.xml
<RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android"
  android:layout_width="match_parent"
  android:layout_height="match_parent"
  android:background="@android:color/white" >

  <TextView
    android:id="@+id/textView1"
    android:layout_width="wrap_content"
    android:layout_height="wrap_content"
    android:layout_centerHorizontal="true"
    android:layout_centerVertical="true"
    android:text="Treehouse loves me!"
    android:textSize="72sp" />
    android:textColor="#FFFFFFFF"
    android:background="#FF000000"


</RelativeLayout>

the problem of teamtreehouse is when I answer the quiz wrong they never tell me what is the correct answer is and that irritates me the most. even if I want to skip it I can't. for example, the code I'm writing above I solved it from my understanding but it keeps telling me it's wrong and I cant go to the next video unless I solve it correctly also there is no way I can know the answer!!!!

1 Answer

Calin Bogdan
Calin Bogdan
14,920 Points

Hello!

The problem is that before the last two arguments, as you can see the orange highlight, there's a syntax error. You forgot to move the "/>" to the end of the XML object. That will fix it.

Hope it helped!