Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress WordPress Theme Development Custom Post Type Templates in WordPress The Portfolio Homepage

Image + Description not showing up? Nothing works

I have been working on this for days, and searched the other questions and solutions thoroughly. Nothing has helped. Here is my code:

<section class="row"> <div class="small-12 columns text-center"> <div class="leader">

        <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>

          <h1><?php the_title(); ?></h1>
          <?php the_content(); ?>

        <?php endwhile; endif; ?>

    </div>
  </div>
</section>

<?php

    $args = array(
        'post_type' => 'portfolio'
    );
    $query = new WP_Query( $args );

?>


<section class="row no-max pad">

  <?php if( $query->have_posts() ) : while( $query->have_posts() ) : $query->the_post(); ?>

      <div class="small-6 medium-4 large-3 columns grid-item">
        <a href="<?php the_permalink(); ?>"><?php the_post_thumbnail('large'); ?></a>
      </div>

  <?php endwhile; endif; wp_reset_postdata(); ?>
</section>

Does anyone see an error that could mess things up?

Wooh! I fixed it. I had 'portfolio' instead of 'portfolio_v2' (long story, it didn't work the first time and then wouldn't let me use plain old 'portfolio'). Anyways, it's fixed.