Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


3,244 Points

In the course we change the preference port settings in MAMP. MySQL will not turn green....start

This is a question from the Wordpress development track: customizing your local server setup on a Mac.

MAMP > preferences > set web & MySQL ports to 80 & 3306.
The apache server is started.... Green. The MySQL server is not started.... Not green.

Can someone help troubleshoot this please. Thanks

1 Answer


Believe it or not, this is a common (but not frequent) MAMP problem. Try this:

  • Shut down Apache and exit MAMP.
  • Type the following at the command line (in Terminal or whatever you use):
killall -9 mysqld
  • Restart MAMP and the servers

If that doesn't work, then you've likely got a problem with the mySQL installation itself, and that'll require some digging and Googling on your part.

3,244 Points

Thanks James.
I actually tried what you suggestion prior to viewing you suggestion.

It had to do with the version of apache and my sequel that had been started in the manual configuration of MAMP. My thought was that there were two instances trying to access the same port.

I posted a different question which details the troubleshooting.

Can you take a look if you have a chance. Thanks