Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Initial incorporation of bootstrap "creative" template not working: Images are missing


Any help is so so so so so so appreciated!

2 Answers

Seth Kroger
Seth Kroger
56,409 Points

This is a Rails app, so I'm re-categorizing it as such.

The you have the images folder in the wrong place. The folder should ideally be in app/assets/ to take advantage of the asset pipeline, or in public/. Since you're using only straight HTML at the moment instead of the Rails helper methods, you should go with public for now.

Thanks for your help, Seth (I have no idea, btw, why my profile pic has "pro" underneath it)! From what I've learned so far, where the images are located should have no effect on the app's ability to locate them, so your information is new to me, thank you. I moved the image to the public/ folder and tried all formats of the file... "header.jpg", "public/header.jpg", "../public/header.jpg" but it is still not loading. I think it might have something to do with the CSS :( and I will continue to tinker... if you can think of anything else let me know! Thanks again.

Wait a minute! This worked for the images sourced directly from the HTML, but not for the first background-image quoted in the LESS file. Nearly there! Thank you!

Seth Kroger
Seth Kroger
56,409 Points

Rails normally uses Sass, not LESS. That's one reason why it's typical for Rails apps to incorporate Bootstrap through the bootstrap-sass gem instead of including the .css/.js files in app/assets.

I will figure out how exactly that works, thank you Seth. I'm just learning but I'm very perseverant!