Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Simple Android App Creating the Screen Layout Getting to Know Our Tools

Installed Java 1.8 but still getting message Android N requires the IDE to be running with Java 1.8 or later! Pls Help.

I have installed Android 2.1 and somehow ended up being Android N. Anyways i keep getting Rendering problems, the detailed message is "Android N requires the IDE to be running with Java 1.8 or later. I followed the link and i installed Java 8 JDK, but i keep getting the same problem. Can you please selp.

By the way am using Mac OSX

2 Answers

Seth Kroger
Seth Kroger
56,407 Points

In creating the project when you're asked for a minimum SDK and target SDK, The dropdowns will have both numeric versions and one alphabetical version (currently N). The alphabetical version a preview of an upcoming Android release, which is for delevopers to try out and test new features, while the numbered ones are the actual released versions of the OS. You want to stick with the numbered versions. There should be versions recommended by Ben in the video, and they can be edited in the app's build.gradle file instead of starting a new project from scratch.

Usen Ekpek
Usen Ekpek
1,634 Points

Seth Kroger

I am having the same issue, but i do not understand when you say there are both numeric versions and one alphabetical version. buy the minimum SDK tab. And you advice one should stick with the numbered versions. Were you referring to the APIs eg: API 15: Android 4.0.3 (IceCreamSandwich)

I have been trying to fix the problem for 5 days, and it's affecting my progress in completing the android track,

Please i need your help. Cheers!

Seth,

Your the best :), I managed to resolve the issue following your advise. I can now continue with the lessons.

Regards, Sulaiman