Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android

[INSTALL_FAILED_DEXOPT] Error When Trying to run app on Genymotion emulator

Hey, I have finished an app and I want to test it out on my Genymotion emulator. However, when I try to run it I get an error message that says "pkg:/data/local/tmp/appname.company.com.blinker Failure [INSTALL_FAILED_DEXOPT]"

After this it gives a dialogue that asks if I want to uninstall the old app and install the new one as the old one could harm the app. I try yes or no but either way I get an 'Unknown failure' in the 'Run' console and the app doesn't run. I am using Android Studio and Windows 8.1.

Here is my Gradle build:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 20
    buildToolsVersion '20.0.0'

    defaultConfig {
        applicationId "blinker.zslasherstudios.com.blinker"
        minSdkVersion 14
        targetSdkVersion 20
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:support-v13:20.0.0'

    compile files('src/main/libs/Parse-1.6.0.jar')
    compile files('libs/commons-io-2.4.jar')
    compile 'com.squareup.picasso:picasso:2.5.2'

}

1 Answer

Update: I have tried a fresh emulator and the same result is returned