Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

CSS Compass Basics Getting Started with Compass Installing Compass

Installing Compass Error

When i try to install compass i get an error saying:

Building native extensions. This could take a while... ERROR: Error installing compass: ERROR: Failed to build gem native extension.

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby -r ./siteconf20140820-5382-tt21mm.rb extconf.rb

mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/include/ruby.h

extconf failed, exit code 1

Gem files will remain installed in /Library/Ruby/Gems/2.0.0/gems/ffi-1.9.3 for inspection. Results logged to /Library/Ruby/Gems/2.0.0/extensions/universal-darwin-13/2.0.0/ffi-1.9.3/gem_make.out

Im completely new to the terminal and command line so I'm completely lost.

6 Answers

hey guys thanks for the replies that didn't work either Sigouy Me, Fortunately i found online i needed to install Xcode. For anyone else having this issue type $ xcode-select --install
You will then get a pop up to install Xcode. After, when you install compass it should work!!

Laura Hill
Laura Hill
13,674 Points

Hi Martin, I am getting the same error - but the Xcode isn't working. I don't want to mess around with my command line too much - but Im using a 2013 iMac. Installing Xcode is all you needed to do?

Jesus Asensio
Jesus Asensio
13,435 Points

Thank you! Same problem and solved!

Tanya Scales
Tanya Scales
Courses Plus Student 1,008 Points

Having the same issue and this fixed it for me. Thank you for this!

In addition: If this doesn't help you and you have Xcode downloaded from the App Store and haven't actually opened it yet, then this may be what you need to do in order to get this working. Xcode needs to finish installing after you accept the user agreement in order for all this to come together.

Sigouy Mo
Sigouy Mo
2,215 Points

Apple updated the Xcode command line tools, which upgraded clang to Apple LLVM version 5.1 (clang-503.0.38) (based on LLVM 3.4svn) and enabled a feature in clang that causes unknown compiler flags to hard error rather than warn.

For now you can work around the issue using:

export ARCHFLAGS="-Wno-error=unused-command-line-argument-hard-error-in-future"

and then try again

sudo gem install compass

Hope it helps.

Source: https://langui.sh/2014/03/10/wunused-command-line-argument-hard-error-in-future-is-a-harsh-mistress/

What command are you typing to install it and what OS are you on? Try

$ gem update --system
$ gem install compass

hey nick thanks for the reply. Those are i commands i wrote and am still having problem.

Martins-MacBook-Pro:~ Martin$ sudo gem update --system Latest version currently installed. Aborting. Martins-MacBook-Pro:~ Martin$ sudo gem install compass Building native extensions. This could take a while... and the whole error thing comes after.

i am on late 2013 macbook pro OS X 10.9.4

no current updates are available

I am also still having these problems ever since I updated to Yosemite or El Capitan (I forgot when I started to see it). I am running on a MacBook Pro, Mid 2012 and currently on OS X 10.11.3. I've also tried all the solutions above.

Marco Boretto
Marco Boretto
29,821 Points

try this out:

sudo gem install -n /usr/local/bin compass

I had the same problem, after installing the Xcode development tools I was still having the error while trying to install compass, I tried the below, according to this post

sudo ln -s /usr/bin/llvm-gcc /usr/bin/gcc-4.2

If that doesn't work out, try agreeing with the Xcode licenses

sudo gcc