Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Java Intro to Java Web Development with Spark Diving into Web Development Meet Spark

Mojo Waters
Mojo Waters
5,748 Points

IntelliJ is not creating resources automatically and yes I am ticking "create resources automatically" no src folder etc

IntelliJ is not creating resources automatically and yes I am ticking "create resources automatically" no src folder and etc.

Does anyone know how to change it, so it creates directories for me automatically. I skipped most of IDE courses :)


Sexual Potatoes
Sexual Potatoes
12,051 Points

Same here. Seems that the video is outdated. Again :|

Check that the IDE has the right path to your jdk files. I had an error message in the bottom of IDEA stating that the JAVA_HOME variable was not correct and when I clicked to change the settings it let me use a dropdown to select jdk 1.8 and that fixed it and created the src folder for me. If you created the project without the correct destination for the jdk then you will need to recreate the project and make sure that it points to the correct jdk or else it wont allow you to use gradle properly

I agree that the outdatedness of these videos is a little frustrating but thats how this industry is, things advance so quickly and Im sure treehouse is trying their best to keep up with the newest technology trends.

Rebekah Smith
Rebekah Smith
7,263 Points

Create a New Project.

This happened to me the first time I used Gradle. IntelliJ downloads resources and sets up Gradle after you first create a New Project with Gradle, but the next time you create a New Project Gradle is already set up and it creates your directory structure automatically.

1 Answer

carlos florez
carlos florez
9,664 Points

To anyone still experiencing this issue:

You need to install Gradle manually to the latest available build.

  1. Install "Scoop" using the Powershell(WIndows) scoop.sh
  2. Install Gradle once Scoop is installed also on the Powershell running the following command line (scoop install gradle)
  3. Open IntelliJ, create new Gradle project and select "Use Local Gradle Distribution" and select the path where Gradle was installed, for me it was ~\scoop\apps\gradle\(Version #).

4.Once project is created, FIle> Settings > Build, Execution, Deployment > Gradle > Tick on Create directory for content roots automatically

For videos where you are downloading an existing project from Treehouse that you need to edit and upload:

1.Edit the Gradle-Properties in the Gradle folder and change the distributionURL from whatever is set to https://services.gradle.org/distributions/gradle-4.3-rc-2-all.zip or any other current version