Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS

IOS Simulator 7.1 does not display app (black screen)

I'm trying to test my app (Crystal Ball) but I can't get it to work in IOS Simulator. I click the "build and run" button and the IOS Simulator starts but it only displays a black screen. Need help solving this problem.

I'm running OS 10.9.2, Xcode 5.1 (5B130a) and IOS Simulator 7.1

Does Xcode return any errors when you run it?

No, the only thing Xcode says is "build succeed

5 Answers

Stone Preston
Stone Preston
42,016 Points

set your storyboard file as the main interface in your project settings. that may fix it.

Deanna Robertazzi
PLUS
Deanna Robertazzi
Courses Plus Student 2,447 Points

How do I set the storyboard file as the main interface? I'm having a similar problem.

Stone Preston
Stone Preston
42,016 Points

If you click your project name at the top of the file explorer on the left side of xcode (the icon looks like a blue print) it should open up you project settings. In the info tab there should be a setting labeled main interface. Set your storyboard file as the main interface

Deanna Robertazzi
PLUS
Deanna Robertazzi
Courses Plus Student 2,447 Points

I clicked on price settings but I don't see anything that can set the storyboard file as the main interface. Maybe I should start the project all over again. :(

Stone Preston
Stone Preston
42,016 Points

I wouldn't start over. It's definitely there. It's in one of the first project settings tabs. Maybe general? I don't have xcode in front of me so it can't say for sure. But there is a drop down in the general settings labeled main interface. Click the drops down and select your storyboard or just type the name of the storyboard in the blank

Stone Preston
Stone Preston
42,016 Points

It's in your project settings, not xcode preferences. See my post from earlier on how to get to your project settings

.