Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby Ruby Core and Standard Library Ruby Standard Library: Part 1 The Ruby Date Class

IRB shows wrong date

I tried tinkering around with the dates, and I found that it gives me a year of 2020 every time I strptime it as "%d/%m/%y":

Date.strptime("13/2/2016", "%d/%m/%y")

gives output of:

=> #<Date: 2020-02-13 ((2458893j,0s,0n),+0s,2299161j)>

I tried another example here:

irb(main):005:0> Date.strptime("13/2/2012", "%d/%m/%y")

This too gives output:

=> #<Date: 2020-02-13 ((2458893j,0s,0n),+0s,2299161j)>

1 Answer

Kourosh Raeen
Kourosh Raeen
23,732 Points

Capitalize y as in:

Date.strptime("13/2/2016", "%d/%m/%Y")

Thanks!